S-SeriesForum.com  

Go Back   S-SeriesForum.com > Member Section > Member Projects

Reply
 
Thread Tools Display Modes
Old 03-08-2016, 11:12 PM   #1
static low 92
Registered User
 
Join Date: Dec 2005
Location: Granite City, Illinois
Posts: 2,959
Powertour Wagon

Debated starting a thread or not. I was bored, so here ya go.

Been on hunt for a wagon for 6months or so to take place of S-10 this year for Powertour, and cause I just want a wagon lol. Found this one on Ebay, which I never look at. Car didn't sell, and I contacted the guy about purchasing outside of Ebay, talked to guy on phone for an hour about it and all details, put a down payment on it that day. Then 10 days later made a road trip to Indiana to buy it.

Rundown: 1965 Malibu/Chevelle wagon, originally a Cali car. 6 cyl/glide. Guy built it in 09. Has a 95 LT1 completely gone through short block, Edelbrock CNC heads, Edelbrock air gap intake, crane cam, 1.6 rocker arms, Headman longtubes, 4L60e with 2800 stall, vintage air setup, painless wiring harness, BeCool radiator/Spal fans, Iditit column, DSE delay wipers/motor, add on sprayer kit, disc brake conversion+power. Full Autometer retro gauges and new gauge/dash housing. Radio in glovebox. MSD optispark, MSD blaster coil and wires.

Car was everything I was looking for. 65 is my favorite year Chevelle, this one was sort of survivor paint with very little cancer, perfect driver quality. Rather be an LS, but LT runs HARD and was put together well so ill deal with that. Needs a bunch of maintenance from sitting basically last 2 years with minimal miles. Car has logged 34K since being built in 09. Drove it home 6 hrs with no issues...

So I wanted a better stance and tore it apart, and snowball effect happened. I ordered all 4 tubular Ebay control arms and swapped to MOOG ball joints, new 2" drop Hotchkis springs, 2" drop CPP spindles, turned rotors, new bearings, stainless brake lines, color matched the calipers. Had a misfire at idle from 3 smoked wires laying on headers, So ordered a new set of MSD wires, NGK plugs, broke shift cable so bought a new one.



















Last edited by static low 92; 03-08-2016 at 11:41 PM.
static low 92 is offline   Reply With Quote
Old 03-08-2016, 11:19 PM   #2
static low 92
Registered User
 
Join Date: Dec 2005
Location: Granite City, Illinois
Posts: 2,959







static low 92 is offline   Reply With Quote
Old 03-08-2016, 11:22 PM   #3
static low 92
Registered User
 
Join Date: Dec 2005
Location: Granite City, Illinois
Posts: 2,959






static low 92 is offline   Reply With Quote
Old 03-08-2016, 11:46 PM   #4
static low 92
Registered User
 
Join Date: Dec 2005
Location: Granite City, Illinois
Posts: 2,959
So where im at now, I assumed with control arms looking like they had a 2" drop in spring pocket I wouldn't need spindles. I was wrong. It doesn't sit lower than it did.

So I need to rip it back apart and swap to drop spindles, and see how it sits. Waiting on rear 3" drop coils to come in still. Ideally like to have it buttoned up and ready for alignment by end of this week. Planning on stealing the wheels off S-10 for a while and running them for a bit. Still need to polish/seal them, and get new rear tires for sure.
static low 92 is offline   Reply With Quote
Old 03-09-2016, 05:42 AM   #5
6SpeedBlazer
SSF Subscriber
Partially retarded
 
6SpeedBlazer's Avatar
 
Join Date: Jan 2005
Location: st louis
Posts: 6,591
I have always been a fan of LT1 motors. they ran strong wen they were fresh.

I had a buddy in highschool his dad had a 93 pace car with 3k original miles. yes 3000 miles on it. the one time we took it out, that thing was strong.

Just a shame the LT motors turned into a GM bastard child.
__________________
-mark
89 s10 blazer slowly rotting away
03 s10 zr2
06 saturn ion
08 TBSS AWD
6SpeedBlazer is offline   Reply With Quote
Old 03-09-2016, 06:36 AM   #6
Hotwire
Subscribed Moderator
I HATE RED!
 
Hotwire's Avatar
 
Join Date: Aug 2001
Location: Summerfield, NC
Posts: 11,728
Damn son, been humping on this thing! Looks like a great base for a daily throw around and have fun ride. Tilt, a/c, man, can't go wrong with that! I'd gladly rock that over the blazer any day!

I don't blame you on keeping the LT1, especially with edelbrock heads? No question about it. You know what and if there's a different cam in it? I loved the grunt my LT4 conversion had, Adam's truck ran like a friggin scalded dog too. My 5.3 is smoother, but doesn't have the raw tenacity that those motors did.
__________________
•Jeff•
00 ZR2 Extended cab (8BenZR2/Angus), 4wd, Beater Extraordinaire
98 Habanero 2, 5.3L L33 V8 swap Click for project SOLD
64 Chevelle Malibu crew cab, 6.0L LQ4 / T56 V8 swap Click for project
Quote:
Originally Posted by Teeleton
Hot wiring is bad news.
Teeleton
Hotwire is offline   Reply With Quote
Old 03-09-2016, 07:15 AM   #7
static low 92
Registered User
 
Join Date: Dec 2005
Location: Granite City, Illinois
Posts: 2,959
Quote:
Originally Posted by Hotwire View Post
Damn son, been humping on this thing! Looks like a great base for a daily throw around and have fun ride. Tilt, a/c, man, can't go wrong with that! I'd gladly rock that over the blazer any day!

I don't blame you on keeping the LT1, especially with edelbrock heads? No question about it. You know what and if there's a different cam in it? I loved the grunt my LT4 conversion had, Adam's truck ran like a friggin scalded dog too. My 5.3 is smoother, but doesn't have the raw tenacity that those motors did.
Crane PowerMax 2033

479/518 Lift

210/224 Duration

Has 1.6 arms which bumps lift.

It has some power left on table with a more aggressive cam, and probably a conversion to SD tune and remove maf. But I was looking at Hotcam specs because I was always impressed with the idle when Mark had his blazer...The specs aren't that far off, I assume just the LSA is different causing the choppy idle. Mine is fairly mild at idle.

Pretty unassuming car, which could be fun. Guy said it went 13.50's with a 2.2 60ft on a street tire.. Which I believe. Because it pulls harder than C-10 with N/A 5.3 did.
static low 92 is offline   Reply With Quote
Old 03-09-2016, 08:16 AM   #8
6SpeedBlazer
SSF Subscriber
Partially retarded
 
6SpeedBlazer's Avatar
 
Join Date: Jan 2005
Location: st louis
Posts: 6,591
Quote:
Originally Posted by Hotwire View Post
Damn son, been humping on this thing! Looks like a great base for a daily throw around and have fun ride. Tilt, a/c, man, can't go wrong with that! I'd gladly rock that over the blazer any day!

I don't blame you on keeping the LT1, especially with edelbrock heads? No question about it. You know what and if there's a different cam in it? I loved the grunt my LT4 conversion had, Adam's truck ran like a friggin scalded dog too. My 5.3 is smoother, but doesn't have the raw tenacity that those motors did.
The lt series motors are a lot more torqy than the ls.
__________________
-mark
89 s10 blazer slowly rotting away
03 s10 zr2
06 saturn ion
08 TBSS AWD
6SpeedBlazer is offline   Reply With Quote
Old 03-09-2016, 08:18 AM   #9
6SpeedBlazer
SSF Subscriber
Partially retarded
 
6SpeedBlazer's Avatar
 
Join Date: Jan 2005
Location: st louis
Posts: 6,591
Quote:
Originally Posted by static low 92 View Post
Crane PowerMax 2033

479/518 Lift

210/224 Duration

Has 1.6 arms which bumps lift.

It has some power left on table with a more aggressive cam, and probably a conversion to SD tune and remove maf. But I was looking at Hotcam specs because I was always impressed with the idle when Mark had his blazer...The specs aren't that far off, I assume just the LSA is different causing the choppy idle. Mine is fairly mild at idle.

Pretty unassuming car, which could be fun. Guy said it went 13.50's with a 2.2 60ft on a street tire.. Which I believe. Because it pulls harder than C-10 with N/A 5.3 did.
The lt4 hot cam is a good grind. I liked it. But its also an OLD cam. I bet there is something better by now.
__________________
-mark
89 s10 blazer slowly rotting away
03 s10 zr2
06 saturn ion
08 TBSS AWD
6SpeedBlazer is offline   Reply With Quote
Old 03-09-2016, 08:42 AM   #10
static low 92
Registered User
 
Join Date: Dec 2005
Location: Granite City, Illinois
Posts: 2,959
Quote:
Originally Posted by 6SpeedBlazer View Post
The lt4 hot cam is a good grind. I liked it. But its also an OLD cam. I bet there is something better by now.
Im sure there is.

But, at this point the car runs fantastic. And im not chomping at the bit to spend unneeded money and then get into having to buy tunercat and retune and potentially turn into that Bermuda triangle of mod issues that I have no desire to deal with after owning the C-10.

This car is sorted fairly well from what I can tell. AFR on wideband is deadnuts though full RPM range. Still retains decent MPG, and will make unsuspecting victims buttpucker lol. My Dad and brother have been susceptible already haha


So purely focued on handling/appearance/ and comfort at this point.
static low 92 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:26 AM.
 


Design by: vBulletin Skins Zone
Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.